Author Topic: Text Command Frustrations  (Read 102 times)

Johnfromfrozennorth

  • Newbie
  • *
  • Posts: 17
Text Command Frustrations
« on: May 25, 2017, 11:07:19 AM »
Hi.
I am using DC 2016 2D.
This morning (and for the past 20 years!)  when I press "T" on the keyboard, the text dialogue box comes up with the previous text string highlighted - ready for me to start typing the next text I want to insert. For some reason; now when I press "T" the cursor has the last text, but the dialogue box is not selected and I have to manually go over there and click on the line with the last text!! arrrgggghhh...

I feel embarrassed to even ask this. I tried restarting DC2016; I tried re-starting the Windows 7 computer;  no luck...

I opened my previous version of DC (23) and no problem there.. it works properly.

What have I done? It's slowing down my drafting by a factor of 2!

P.S. This has also happened to me with the rotate command. Sometimes (when Drag Mode is disabled) the rotation angle value is not highlighted and sometimes it is. When highlighted, progressive rotations to get it just right is very fast and easy - no need to first click inside the dialogue box)I have not figured out how to control this??? Help please

John

DrollTroll

  • Kindly Curmudgeon
  • Administrator
  • *****
  • Posts: 4092
Re: Text Command Frustrations
« Reply #1 on: May 25, 2017, 12:12:12 PM »
Check Help/About DesignCAD -- what's the full version number?

If it's 26.1 or 26.0, try installing the 26.2 update patch available here: http://forum.designcadcommunity.com/index.php?topic=6810.0  and let us know if that helps.

*afterthought* Also, be sure you aren't in Preset Point Mode -- that seems to do odd things with dialog focus sometimes.
« Last Edit: May 25, 2017, 12:13:52 PM by DrollTroll »
2016 marks my 24th year in DesignCAD-Land!

Pearco

  • Hero Member
  • *****
  • Posts: 823
Re: Text Command Frustrations
« Reply #2 on: May 25, 2017, 04:34:09 PM »
John / DT;
I get the same thing with 26.2. I'm not in point select mode. If I select "T" it always high lights the last text entry unless you hit delete before entering new text. If you select "T" and go to the red down arrow and select say the drawing name it usually deletes the old text  and gives you what you are after. If memory serves it has been this way for a couple of versions. I have gotten into the habit of selecting text and automatically hit delete before entering new text. It does have some weird actions.
Jim
User since ProDesign 1.5

Johnfromfrozennorth

  • Newbie
  • *
  • Posts: 17
Re: Text Command Frustrations
« Reply #3 on: May 26, 2017, 11:20:11 AM »
DT
Using Version 26.2
You are right. In preset point mode (ppm), the "T" command does not highlight the previous text in the dialogue box.
However, I doubt I was in that mode - but the icon is close to the double line command (which I use a lot), so maybe I pressed it inadvertently.

The problem seems intermittent and not repeatable.

About 2 hours after putting up my post - it returned to normal.

Maybe I had selected that preset point mode...

I'll post back if it happens again (after checking if the ppm was selected).

Thanks for the quick reply.
John

Rob S

  • Hero Member
  • *****
  • Posts: 4262
    • Construction Estimating Program for General Contractors
Re: Text Command Frustrations
« Reply #4 on: May 26, 2017, 02:53:13 PM »
I was checking this as well, and for me all recent versions the text command comes up with the last entry highlighted with the edit box in focus, and this same text can be re-inserted with a single mouse-click, or edited by clicking within it, or typed over by just starting to type.

This is consistent as I remember it for quite some time now. 

I don't use preset point mode, so no experience in that.  A quick test shows that if you do have a point preset before calling up the text command, V26.2  enters the last used text at that location, no chance to edit.   To create or edit a new text line, you must have no points set.  Tab key shifts the focus to the edit box.
User since Pro-design