Author Topic: MoveToFront  (Read 2589 times)

paulerens

  • Hero Member
  • *****
  • Posts: 915
MoveToFront
« on: December 05, 2008, 01:40:33 AM »
In the SDK version 17

The macro   > MoveToFront{} is wrong
It should by > MoveToTop{}

bdeck

  • Hero Member
  • *****
  • Posts: 785
Re: MoveToFront
« Reply #1 on: January 21, 2009, 07:47:27 AM »
High Paul, I always have to think about these commands, because their names and functions are unclear.

In addition to your suggestion, here's my suggestion on how to improve both the macro command names and the menu command names:

MoveToBack---- -should be---- MoveToBottom
MoveAfter   ---- -should be ----MoveBelow
MoveInFrontOf--- should be ----MoveAbove

These commands affect not just the display order, but the entity number as well.

Consistent wording that serves both purposes should be adapted. "MoveAfter" is the worst offfender.

Note that gravity snap will allways seek the lowest/oldest of common points, not the highest/newest.

Its OK to keep the old function names for vestigial purposes.
« Last Edit: January 21, 2009, 07:50:23 AM by bdeck »

paulerens

  • Hero Member
  • *****
  • Posts: 915
Re: MoveToFront
« Reply #2 on: January 21, 2009, 04:57:56 PM »
Hello bdeck,

My intention is not to criticize the intention of the text
But simple, if you write the macro as proposed in the SDK.version 17 . Then it will not work

 The SDK is written > MoveToFront{}  but the macro does not work.
If you write, > MoveToTop{} the macro does.

In macroCMD is witten (MoveToTop=ID_MOVETOTOP)
« Last Edit: January 22, 2009, 08:55:41 AM by paulerens »