Recent Posts

Pages: [1] 2 3 ... 10
1
Looking For Help? / Re: Hatch covers up text
« Last post by DCdosuser on Today at 02:01:33 PM »
adriank has a solution for me.  Normally I use a black background.  For the colors to work when I print a PDF I had to go to a white background.  In areas that needed to be black I used a black hatch (WIN_SOLID).  I was trying to put a white text in the areas of black hatch.  Just as adriank said, the text appeared black.  After changing to a gray (R:250, G:250, B:250) the text showed up.  Anything closer to white, 251 for example, would not show up in the black field.  Thanks to everyone.  I will incorporate the other suggestions, as they are all good. Thanks again.
2
Looking For Help? / Re: Hatch covers up text
« Last post by adriank on Today at 10:57:48 AM »
Sorry if I confused you.
I have assigned the up and down arrows to move the display order, I can't tell you what the default assignment is for those commands because I've over-written all the standard assignments.
If you go to options/keyboard & select the 'edit' category the move to top & move to back commands are about 1/2 way down the list.
When you select any command it displays the default keys in the 'current keys' window.

If there is none it'll be blank but you can assign any key you like by selecting it in the dropdown list to the right.
Don't forget to 'save as default' before you exit or the assignment won't work.

As Rob suggests, post a file up for us to look at.
Rob also suggested you disable the layer with the hatch in it after you get it to display where you want it - that's a good idea because it's easy to select a background hatch by mistake if you wander too far from the entity you are trying to select, and when it's selected it will always display on top of everything.
A side note - if you do select and delete the hatch by mistake, and then undo the mistake the hatch reappears on top regardless of where you had set it to display, so you need to re-set the display order again.
What colours have you got for the hatch pattern and text? (and what colour is your background set as?)
White text on a white background will display black, so if your hatch is black the white text will still display black and 'disappear' even if it is on top. To solve that one I would set the text as a very pale grey - you need to be a couple of graduations off the background colour before it will display true colour over your hatch.
3
Looking For Help? / Re: Hatch covers up text
« Last post by bdeck on Today at 10:49:26 AM »
Hello DCdosuser,

After doing a MoveToTop or MoveToBottom occassionally the change will not be immediately reflected on screen.

In that case,  regen, zoom, or zoom window, or even a mouse click may render it correctly.

I like adriank's idea of assigning a keyboard shortcut to move text to top or bottom.

Instead of a keyboard shortcut, I execute one of the following macros labeled "bb.d3m" and "tt.d3m" from the command line, after selecting the entity I want to move.

The macros may also be helpful when images and drawn line entities overlap  (especially if one has not yet set the 'Display Geometry On Top Of Images' option, as adriank previously suggested).

Code: [Select]
'''  tt.d3m    macro to move selected entites to top of display order
>MoveToTop
{
  }

Code: [Select]
'''  bb.d3m    macro to move selected entites to bottom of display order
>MoveToBack
{
  }

Here is a link to a discussion of how to save and use a macro.
http://forum.designcadcommunity.com/index.php?topic=1047.msg10817#msg10817

See attached image for other ideas.
4
Looking For Help? / Re: Hatch covers up text
« Last post by Rob S on Today at 08:21:10 AM »
Care to post the file you are working on (or a sample of the problem) for us to see what is going on??
5
Looking For Help? / Re: Hatch covers up text
« Last post by DCdosuser on Today at 08:04:55 AM »
Rob S - I have done that (both with Move to Top and with Move in Front of... Text is still hidden.

adriank - Not sure what you mean by "hit the up arrow".  If I select the text and hit the up arrow on the key pad, nothing happens.  I don't have either Move to Top or Move in Front of... assigned to any keys.  If I click the up arrow in the layer box, it just switches the order of my layers.  I just select the text/ Edit/ Selection Edit/ Display Order/ Move to Top (or Move in Front of...). I have tried the reverse also, by selecting the hatch/ Edit/ Selection Edit/ Display Order/ Move to Back.  This doesn't work either.
6
Looking For Help? / Re: Hatch covers up text
« Last post by adriank on Today at 06:56:20 AM »
Move to top and move to back are so important to me that I have assigned the up and down arrow keys to do the job.
Remember it is the selected item you are moving so to move the text on top, select it and hit the up arrow. Job done!

While we are discussing using solid hatch to obscure something deliberately, it's useful to know that you can assign 'paper colour' to a hatch which effectively makes it disappear. It also makes whatever entities under it disappear too which is a good trick to know.
I use that often. If for instance I've hatched a floor pattern in a room and i then place a piece of furniture on it I don't want to see the hatch under the furniture so I place another solid hatch the same shape as the furniture under it but over the floor pattern.
The typically weird DCad method to do that is that you can't assign 'paper colour' to a hatch before drawing it - you have to draw it in another colour and then change it in the info box. You also cannot batch convert to 'paper colour', you have to select them one by one!

Adrian
7
Looking For Help? / Re: Hatch covers up text
« Last post by Rob S on Today at 06:39:16 AM »
Select the text first, then run the command, no left click after
8
Looking For Help? / Re: Hatch covers up text
« Last post by DCdosuser on Today at 06:01:43 AM »
I tried solution proposed by REF.  My options were:
Move to Top
Move to Back
Move in Front of...
Move After...
I tried both Move to Top and Move in Front of... If I selected Move in Front of..., the cursor turned into a pointing hand.  I used the cursor to point to the hatch area and left clicked.  The cursor then turned back into the normal selection cursor and the text remained selected and visible.  However, once I clicked elsewhere or selected another entity, the text became hidden again.
I then tried Move to Top with the same result except the cursor did not change to a pointing hand.  Again, the text became hidden.
Haven't tried suggestion by Rob S yet.
9
Looking For Help? / Re: Hatch covers up text
« Last post by Rob S on July 18, 2019, 09:08:40 PM »
After moving the hatch to the back, it also might help to place the hatch on a separate layer, and turn off editing for that layer

Otherwise everytime you select the hatch, accidentally or on purpose, it will pop to the front again.

At least that is how it works with embedded images.
10
Looking For Help? / Re: Hatch covers up text
« Last post by REF on July 18, 2019, 09:05:10 PM »
Select the Text, then go to
Menu: Edit / Selection Edit / Display Order / Move To Front
Pages: [1] 2 3 ... 10